Campaign: iPhone

Reduce iOS version!

Not everyone can run iOS later than 3.1.2, so the requirement of 3.1.3 is an artificial limiter. Please re-compile so that as many 3.x users can enjoy this great app!

Submitted by

Voting

-4 votes